RoutingConditions Class

RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRoutingConditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RoutingConditions : IDisposable

The RoutingConditions type exposes the following members.

Constructors
 NameDescription
Public methodRoutingConditions Constructs a new instance of a RoutingConditions object with an indicated error level for conditions that do not meet any routing preference rule.
Top
Properties
 NameDescription
Public propertyErrorLevel The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyPreferredJunctionType The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.
Top
Methods
 NameDescription
Public methodAppendCondition Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public methodClear Clear all existing conditions
Public methodDisposeReleases all resources used by the RoutingConditions
Public methodGetConditionAt Gets the routing condition at the specified index position.
Public methodGetNumberOfConditions Gets the number of included routing conditions.
Top
See Also