FileSaveDialog Class

This class allows an add-in to prompt the user with the Revit dialog used to navigate to and select an existing or new file path. This dialog is typically used to enter a file name for saving or exporting.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIFileDialog
    Autodesk.Revit.UIFileSaveDialog

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FileSaveDialog : FileDialog

The FileSaveDialog type exposes the following members.

Constructors
 NameDescription
Public methodFileSaveDialog Constructs a new instance of a File Save dialog.
Top
Properties
 NameDescription
Public propertyDefaultFilterEntry The default entry (from the filter) to be selected in the dialog.
(Inherited from FileDialog)
Public propertyFilter The filter string representing a collection of extensions allowed by the dialog.
(Inherited from FileDialog)
Public propertyInitialFileName The initial file name to be shown for this save operation.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FileDialog)
Public propertyTitle The title to show on the dialog.
(Inherited from FileDialog)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FileDialog)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetSelectedModelPath Returns the selected file path chosen by the user.
(Inherited from FileDialog)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodShow Shows the dialog using the stored settings.
(Inherited from FileDialog)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

The behavior and appearance of this dialog matches the Revit "Save as" dialog. This is a general-purpose dialog for saving any given file type, and the Options shown in the dialog for Revit projects and families will not be shown. To prompt the user to save the active Revit document specifically, use UIDocument.SaveAs(UISaveAsOptions) instead.

The user will be requested to select or enter a file name matching the corresponding filter. If an existing file is selected, there will be a default prompt about overwriting the file shown, where the user can confirm or cancel this file selection.

The folder location shown when the dialog is displayed defaults to the most recently used file location for saving or exporting.

Use of this dialog does not actually save an existing file, but it will provide the selected file path back to the caller to take any action necessary.

See Also