FileDialog Class

Base class supporting display of the dialog used to navigate to and select a file from Autodesk Revit.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FileDialog : IDisposable

The FileDialog type exposes the following members.

Properties
 NameDescription
Public propertyDefaultFilterEntry The default entry (from the filter) to be selected in the dialog.
Public propertyFilter The filter string representing a collection of extensions allowed by the dialog.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyTitle The title to show on the dialog.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FileDialog
Public methodGetSelectedModelPath Returns the selected file path chosen by the user.
Public methodStatic memberIsValidFilterString Determines if the input string is acceptable as input for a FileDialog filter string.
Public methodShow Shows the dialog using the stored settings.
Top
See Also