PhaseArray Class

An array that contains phase objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBPhaseArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PhaseArray : APIObject, IEnumerable

The PhaseArray type exposes the following members.

Constructors
 NameDescription
Public methodPhaseArrayInitializes a new instance of the PhaseArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyItemGets or sets a phase at a specified index within the array.
Public propertySizeReturns the number of phases that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the phase to the end of the array.
Public methodClearRemoves every phase from the array, rendering it empty.
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodInsertInsert the specified phase into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Top
See Also