TextEditorOptions Class

Provides access to settings that control Revit's Text Editor appearance and functionality.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UITextEditorOptions

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TextEditorOptions : IDisposable

The TextEditorOptions type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyShowBorder Show the border box around the text during editing.
Public propertyShowOpaqueBackground Show opaque background behind the text during editing.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TextEditorOptions
Public methodStatic memberGetTextEditorOptions Returns the current Revit instance's TextEditorOptions.
Top
Remarks
These settings are stored in the Revit.ini file. All documents in Revit instances which use this Revit.ini will follow these settings.
Example
public void SetEditorOptions()
{
    TextEditorOptions editorOptions = TextEditorOptions.GetTextEditorOptions();
    editorOptions.ShowBorder = false;
    editorOptions.ShowOpaqueBackground = true;
}
See Also