ExporterIFCUtilsGetLegacyStairOrRampComponents Method |
Gets the components of a stair or ramp.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IFCLegacyStairOrRamp GetLegacyStairOrRampComponents(
ExporterIFC exporterIFC,
Element element
)
Public Shared Function GetLegacyStairOrRampComponents (
exporterIFC As ExporterIFC,
element As Element
) As IFCLegacyStairOrRamp
public:
static IFCLegacyStairOrRamp^ GetLegacyStairOrRampComponents(
ExporterIFC^ exporterIFC,
Element^ element
)
static member GetLegacyStairOrRampComponents :
exporterIFC : ExporterIFC *
element : Element -> IFCLegacyStairOrRamp
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- element Element
-
The legacy stair or ramp element.
Return Value
IFCLegacyStairOrRamp
The LegacyStairOrRamp that contains the components. NULL means the components can't be determined.
Exceptions
See Also