FilterDialog Class

Allows display of the dialog used to create and edit FilterElements in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIFilterDialog

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterDialog : IDisposable

The FilterDialog type exposes the following members.

Constructors
 NameDescription
Public methodFilterDialog(Document, ElementId) Constructs a new instance of the FilterDialog class, while setting the id of the FilterElement to be selected when the dialog is shown.
Public methodFilterDialog(Document, String) Constructs a new instance of the FilterDialog class, while setting the name of the new ParameterFilterElement to be created and selected for editing.
Top
Properties
 NameDescription
Public propertyFilterToSelect The filter element to be selected once Show is invoked.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyNewFilterId The ElementId of the new filter created. The value is populated after Show method is executed.
Public propertyNewFilterName The name of the new ParameterFilterElement to be created and selected once Show is invoked.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FilterDialog
Public methodShow Shows the FilterDialog editing dialog to the user.
Top
Remarks
The class provides the option to launch the dialog by selecting an existing FilterElement, or automatically creating a new ParameterFilterElement. In both cases the affected element will be selected for editing. Note that the user may opt to add, delete or edit any of the available filter elements (or make no changes at all).
See Also