FilterDialog(Document, ElementId) Constructor |
Constructs a new instance of the FilterDialog class,
while setting the id of the FilterElement to be selected when the dialog is shown.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilterDialog(
Document doc,
ElementId filterToSelect
)
Public Sub New (
doc As Document,
filterToSelect As ElementId
)
public:
FilterDialog(
Document^ doc,
ElementId^ filterToSelect
)
new :
doc : Document *
filterToSelect : ElementId -> FilterDialog
Parameters
- doc Document
-
The document that owns the FilterElements displayed and edited in the dialog.
- filterToSelect ElementId
-
The FilterElement to be selected.
If InvalidElementId, then the first (if any) available FilterElement will be selected.
Exceptions
Remarks
Show the dialog with the Show() method after setting the desired options.
See Also