FilterDialogNewFilterName Property |
The name of the new ParameterFilterElement to be created and selected once Show is invoked.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string NewFilterName { get; set; }
Public Property NewFilterName As String
Get
Set
public:
property String^ NewFilterName {
String^ get ();
void set (String^ value);
}
member NewFilterName : string with get, set
Property Value
String
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: newFilterName is an empty string.
-or-
When setting this property: newFilterName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
When setting this property: The supplied filter name newFilterName is not unique.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also