FilterDialogFilterToSelect Property |
The filter element to be selected once Show is invoked.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId FilterToSelect { get; set; }
Public Property FilterToSelect As ElementId
Get
Set
public:
property ElementId^ FilterToSelect {
ElementId^ get ();
void set (ElementId^ value);
}
member FilterToSelect : ElementId with get, set
Property Value
ElementId
The default is InvalidElementId, resulting in selecting the first available (if any) FilterElement.
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The supplied ElementId id is not of a FilterElement.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also