ExporterIFCGetLayerNameForPresentationLayer Method |
Get the layer name associated with an element from the default layer mapping table.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string GetLayerNameForPresentationLayer(
Element pElement,
ElementId categoryId
)
Public Function GetLayerNameForPresentationLayer (
pElement As Element,
categoryId As ElementId
) As String
public:
String^ GetLayerNameForPresentationLayer(
Element^ pElement,
ElementId^ categoryId
)
member GetLayerNameForPresentationLayer :
pElement : Element *
categoryId : ElementId -> string
Parameters
- pElement Element
-
The element.
- categoryId ElementId
-
The category id of the element.
Return Value
String
The layer name.
Exceptions
See Also