CurveElementSetSketchPlaneAndCurve Method |
Sets the sketch plane and the curve for this CurveElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSketchPlaneAndCurve(
SketchPlane sketchPlane,
Curve curve
)
Public Sub SetSketchPlaneAndCurve (
sketchPlane As SketchPlane,
curve As Curve
)
public:
void SetSketchPlaneAndCurve(
SketchPlane^ sketchPlane,
Curve^ curve
)
member SetSketchPlaneAndCurve :
sketchPlane : SketchPlane *
curve : Curve -> unit
Parameters
- sketchPlane SketchPlane
- The new sketch plane.
- curve Curve
- The new curve.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown if the argument is .
|
InvalidOperationException |
Thrown if the CurveElement is CurveByPoints or belongs to a Path3d element. -- or --
Thrown if the sketch plane is set on a DetailCurve. -- or --
Thrown if the sketch plane is not suitable. -- or --
Thrown if the CurveElement belongs to a sketch-based element. -- or --
Thrown if modifying the sketch plane is not allowed. -- or --
Thrown if the CurveElement cannot be moved out of its sketch plane. -- or --
Thrown if the input curve is of a type different from the current. -- or --
Thrown if the input curve is bound and the current is not or vice versa. -- or --
Thrown if the input curve is helical. -- or --
Thrown if the input curve lies outside of the SketchPlane of the current curve.
|
Remarks Unlike the setters of
SketchPlane and
GeometryCurve,
this method will reset relationships between the two properties and with other elements.
To set a geometry curve which belongs to a sketch-based elements, use
GeometryCurve
See Also