CurveElementGeometryCurve Property |
Geometry curve of the curve element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Curve GeometryCurve { get; set; }
Public Property GeometryCurve As Curve
Get
Set
public:
property Curve^ GeometryCurve {
Curve^ get ();
void set (Curve^ value);
}
member GeometryCurve : Curve with get, set
Property Value
Curve
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown if the argument is .
|
ArgumentNullException |
Thrown if the argument is .
|
ArgumentException |
Thrown if the input curve is of a type different from the current. -- or --
Thrown if the input curve is bound and the current is not or vice versa. -- or --
Thrown if the input curve is helical. -- or --
Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints.
|
RemarksWhen setting this property, any curves that this curve is currently joined to will affect the result -
the final geometry of this curve and of the joined curves may change.
To avoid the effect of existing joins, use
SetGeometryCurve(Curve, Boolean) with true passed ot overrideJoins.
After the curve geometry is set, other nearby curves may join to the new curve geometry.
See Also