CurveElementSketchPlane Property |
The sketch plane the curve element lies in.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual SketchPlane SketchPlane { get; set; }
Public Overridable Property SketchPlane As SketchPlane
Get
Set
public:
virtual property SketchPlane^ SketchPlane {
SketchPlane^ get ();
void set (SketchPlane^ value);
}
abstract SketchPlane : SketchPlane with get, set
override SketchPlane : SketchPlane with get, set
Property Value
SketchPlane
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown if the argument is .
|
InvalidOperationException |
Thrown if the CurveElement is CurveByPoints or belongs to a Path3d element. -- or --
Thrown if the sketch plane is set on a DetailCurve. --or--
Thrown if the sketch plane is not parallel to the existing plane. -- or --
Thrown if the sketch plane is not suitable. -- or --
Thrown if the CurveElement belongs to a sketch-based element. -- or --
Thrown if modifying the sketch plane is not allowed. -- or --
Thrown if the CurveElement cannot be moved out of its sketch plane.
|
RemarksThe new sketch plane must be parallel to the existing sketch plane. Setting this property
is not permitted for detail curves because they must be placed only on view-specific planes.
See Also