MassInstanceUtilsRemoveMassLevelDataFromMassInstance Method

Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void RemoveMassLevelDataFromMassInstance(
	Document document,
	ElementId massInstanceId,
	ElementId levelId
)

Parameters

document  Document
The Document.
massInstanceId  ElementId
The ElementId of the mass instance.
levelId  ElementId
The ElementId of the Level to disassociate from the mass instance.
Exceptions
ExceptionCondition
ArgumentException The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
ArgumentNullException A non-optional argument was null
Remarks
Alternatively, you could just delete the MassLevelData.
See Also