Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void RemoveMassLevelDataFromMassInstance( Document document, ElementId massInstanceId, ElementId levelId ) |
Visual Basic |
---|
Public Shared Sub RemoveMassLevelDataFromMassInstance ( _ document As Document, _ massInstanceId As ElementId, _ levelId As ElementId _ ) |
Visual C++ |
---|
public: static void RemoveMassLevelDataFromMassInstance( Document^ document, ElementId^ massInstanceId, ElementId^ levelId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Document.
- massInstanceId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.
- levelId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Level to disassociate from the mass instance.
Remarks
Alternatively, you could just delete the MassLevelData.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |