LinkNode Class

An output node that represents a linked Revit document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBGroupNode
      Autodesk.Revit.DBLinkNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LinkNode : GroupNode

The LinkNode type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode)
Public propertyNodeName A readable name of the output node.
(Inherited from RenderNode)
Public propertySymbolId Identifies the Id of the symbol associated with the node.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RenderNode)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetDocument Returns the document associated with the link.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTransform A transformation matrix associated with the node.
(Inherited from GroupNode)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
See Also