IExportContextOnLinkBegin Method |
This method marks the beginning of a link instance to be exported.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxRenderNodeAction OnLinkBegin(
LinkNode node
)
Function OnLinkBegin (
node As LinkNode
) As RenderNodeAction
RenderNodeAction OnLinkBegin(
LinkNode^ node
)
abstract OnLinkBegin :
node : LinkNode -> RenderNodeAction
Parameters
- node LinkNode
-
Return Value
RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip processing this link instance,
or return RenderNodeAction.Proceed otherwise.
Example
public RenderNodeAction OnLinkBegin(LinkNode node)
{
ElementId symbolId = node.SymbolId;
RevitLinkType linkType = m_document.GetElement(symbolId) as RevitLinkType;
String linkDocumentName = linkType.Name;
m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()));
return RenderNodeAction.Proceed;
}
public void OnLinkEnd(LinkNode node)
{
m_TransformationStack.Pop();
}
Public Function OnLinkBegin(node As LinkNode) As RenderNodeAction Implements IExportContext.OnLinkBegin
Dim symbolId As ElementId = node.SymbolId
Dim linkType As RevitLinkType = TryCast(m_document.GetElement(symbolId), RevitLinkType)
Dim linkDocumentName As [String] = linkType.Name
m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()))
Return RenderNodeAction.Proceed
End Function
Public Sub OnLinkEnd(node As LinkNode) Implements IExportContext.OnLinkEnd
m_TransformationStack.Pop()
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also