DocumentNewOpening(Element, CurveArray, Boolean) Method |
Creates a new opening in a roof, floor and ceiling.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Opening NewOpening(
Element hostElement,
CurveArray profile,
bool bPerpendicularFace
)
Public Function NewOpening (
hostElement As Element,
profile As CurveArray,
bPerpendicularFace As Boolean
) As Opening
public:
Opening^ NewOpening(
Element^ hostElement,
CurveArray^ profile,
bool bPerpendicularFace
)
member NewOpening :
hostElement : Element *
profile : CurveArray *
bPerpendicularFace : bool -> Opening
Parameters
- hostElement Element
- Host element of the opening. Can be a roof, floor, or ceiling.
- profile CurveArray
- Profile of the opening.
- bPerpendicularFace Boolean
- True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.
Return Value
Opening If successful, an Opening object is returned.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the host element does not exist in the given document. |
See Also