ViewType Enumeration

An enumerated type listing available view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ViewType
Members
Member nameValueDescription
Undefined0Undefined/unspecified type of view.
FloorPlan1Floor plan type of view.
CeilingPlan2Reflected ceiling plan type of view.
Elevation3Elevation type of view.
ThreeD43-D type of view.
Schedule5Schedule type of view.
DrawingSheet6Drawing sheet type of view.
ProjectBrowser7The project browser view.
Report8Report type of view.
DraftingView10Drafting type of view.
Legend11Legend type of view.
SystemBrowser12The MEP system browser view.
EngineeringPlan115Structural plan or Engineering plan type of view.
AreaPlan116Area plan type of view.
Section117Cross section type of view.
Detail118Detail type of view.
CostReport119Cost Report view.
LoadsReport120Loads Report view.
PresureLossReport121Pressure Loss Report view.
ColumnSchedule122Column Schedule type of view.
PanelSchedule123Panel Schedule Report view.
Walkthrough124Walk-Through type of 3D view.
Rendering125Rendering type of view.
SystemsAnalysisReport126 Systems analysis report view.
Internal214Revit's internal type of view
See Also