Transform2D(UV, UV, UV) Constructor |
Constructs the transformation by specifying the vectors and the origin.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform2D(
UV uVec,
UV vVec,
UV origin
)
Public Sub New (
uVec As UV,
vVec As UV,
origin As UV
)
public:
Transform2D(
UV^ uVec,
UV^ vVec,
UV^ origin
)
new :
uVec : UV *
vVec : UV *
origin : UV -> Transform2D
Parameters
- uVec UV
-
The image of (1, 0) under OfVector(UV).
- vVec UV
-
The image of (0, 1) under OfVector(UV).
- origin UV
-
The image of (0, 0) under OfPoint(UV).
This defines the translational part of the transform.
Exceptions
See Also