AnnotationMultipleAlignmentUtils Class

A helper providing functionality related to elements that can be aligned to one another. An element that wants to be able to align to other alignable elements using the Multiple Alignment buttons should implement this helper class.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAnnotationMultipleAlignmentUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnnotationMultipleAlignmentUtils : IDisposable

The AnnotationMultipleAlignmentUtils type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the AnnotationMultipleAlignmentUtils
Public methodStatic memberElementSupportsMultiAlign Returns true if element can be aligned to other similar elements.
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodStatic memberGetAnnotationOutlineWithoutLeaders Gets the four corners of the alignable element in model space without its leaders.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberMoveWithAnchoredLeaders Moves the element while keeping the leader end points anchored.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also