ImporterIFCHybridElementImport Method |
Note: This API is now obsolete.
Imports IFC Elements using non-open-source framework.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IFCHybridImport' class instead.")]
public IList<ElementId> HybridElementImport(
Document doc,
string file
)
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IFCHybridImport' class instead.")>
Public Function HybridElementImport (
doc As Document,
file As String
) As IList(Of ElementId)
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IFCHybridImport' class instead.")]
IList<ElementId^>^ HybridElementImport(
Document^ doc,
String^ file
)
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IFCHybridImport' class instead.")>]
member HybridElementImport :
doc : Document *
file : string -> IList<ElementId>
Parameters
- doc Document
-
Document into which Import is done.
- file String
-
Full path of the file to import.
Return Value
IListElementId
Elements imported using non-open-source framework.
Exceptions
See Also