FaceArray Class

An array that contains faces.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBFaceArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FaceArray : APIObject, IEnumerable

The FaceArray type exposes the following members.

Constructors
 NameDescription
Public methodFaceArrayInitializes a new instance of the FaceArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyItemGets or sets a face at a specified index within the array.
Public propertySizeReturns the number of faces that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the face to the end of the array.
Public methodClearRemoves every face from the array, rendering it empty.
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodInsertInsert the specified face into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Top
See Also