MullionTypeSet Class

A set that contains mullion types.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBMullionTypeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MullionTypeSet : APIObject, 
	IEnumerable

The MullionTypeSet type exposes the following members.

Constructors
 NameDescription
Public methodMullionTypeSetInitializes a new instance of the MullionTypeSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertySizeReturns the number of mullion types that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every mullion type from the set, rendering it empty.
Public methodContainsTests for the existence of a mullion type within the set.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEraseRemoves a specified mullion type from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInsert the specified mullion type into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also