BoundaryValidation Class

Curve loop validators.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBoundaryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BoundaryValidation : IDisposable

The BoundaryValidation type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the BoundaryValidation
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberIsValidBoundaryOnSketchPlane Indicates if the given curve loops compose a valid boundary on the sketch plane.
Public methodStatic memberIsValidBoundaryOnView Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
Public methodStatic memberIsValidHorizontalBoundary Identifies whether the given curve loops compose a valid horizontal boundary.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also