BoundaryValidationIsValidBoundaryOnSketchPlane Method |
Indicates if the given curve loops compose a valid boundary on the sketch plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidBoundaryOnSketchPlane(
SketchPlane sketchPlane,
IList<CurveLoop> curveLoops
)
Public Shared Function IsValidBoundaryOnSketchPlane (
sketchPlane As SketchPlane,
curveLoops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsValidBoundaryOnSketchPlane(
SketchPlane^ sketchPlane,
IList<CurveLoop^>^ curveLoops
)
static member IsValidBoundaryOnSketchPlane :
sketchPlane : SketchPlane *
curveLoops : IList<CurveLoop> -> bool
Parameters
- sketchPlane SketchPlane
-
The sketch plane.
- curveLoops IListCurveLoop
-
The curve loops to be checked.
Return Value
Boolean
True if the given curve loops are valid as described above, false otherwise.
Exceptions
Remarks
The curve loops are valid if projections of the loops onto the sketch plane do not intersect each other;
each curve loop is closed; input curves do not contain any helical curve;
and each loop is planar and lies on a plane parallel to the sketch plane, but not necessarily the same plane.
See Also