BoundaryValidationIsValidBoundaryOnView Method |
Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidBoundaryOnView(
Document document,
ElementId viewId,
IList<CurveLoop> curveLoops
)
Public Shared Function IsValidBoundaryOnView (
document As Document,
viewId As ElementId,
curveLoops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsValidBoundaryOnView(
Document^ document,
ElementId^ viewId,
IList<CurveLoop^>^ curveLoops
)
static member IsValidBoundaryOnView :
document : Document *
viewId : ElementId *
curveLoops : IList<CurveLoop> -> bool
Parameters
- document Document
-
The document.
- viewId ElementId
-
The view Id.
- curveLoops IListCurveLoop
-
The curve loops to be checked.
Return Value
Boolean
True if the given curve loops are valid as described above, false otherwise.
Exceptions
Remarks
The curve loops are valid if projections of the loops onto the views's detail sketch plane do not intersect each other;
each curve loop is closed; input curves do not contain any helical curve;
and each loop is planar and lies on a plane parallel to the views's detail sketch plane, but not necessarily the same plane.
See Also