BoundaryValidationIsValidHorizontalBoundary Method |
Identifies whether the given curve loops compose a valid horizontal boundary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidHorizontalBoundary(
IList<CurveLoop> curveLoops
)
Public Shared Function IsValidHorizontalBoundary (
curveLoops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsValidHorizontalBoundary(
IList<CurveLoop^>^ curveLoops
)
static member IsValidHorizontalBoundary :
curveLoops : IList<CurveLoop> -> bool
Parameters
- curveLoops IListCurveLoop
-
The curve loops to be checked.
Return Value
Boolean
True if the given curve loops are valid as described above, false otherwise.
Exceptions
Remarks
The curve loops are valid if projections of the loops onto a horizontal(XY) plane do not intersect each other;
each curve loop is closed; input curves do not contain any helical curve;
and each loop is planar and lies on a plane parallel to the horizontal(XY) plane, but not necessarily the same plane.
See Also