EdgeArrayArray Class

An array of edge arrays.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBEdgeArrayArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EdgeArrayArray : APIObject, 
	IEnumerable

The EdgeArrayArray type exposes the following members.

Constructors
 NameDescription
Public methodEdgeArrayArrayInitializes a new instance of the EdgeArrayArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItemGets or sets an edge array at a specified index within the array.
Public propertySizeReturns the number of edge arrays that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the edge array to the end of the array.
Public methodClearRemoves every edge array from the array, rendering it empty.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInsert the specified edge array into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Example
public void GetEdgeArrayArray(Autodesk.Revit.ApplicationServices.Application app, Autodesk.Revit.DB.Element element)
{
    // Get geometry element of the selected element
    Options geoOptions = app.Create.NewGeometryOptions();
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);
    // Get geometry object
    foreach (GeometryObject o in geoElement)
    {
        Solid solid = o as Solid;
        if (null != solid)
        {
            foreach (Face face in solid.Faces)
            {
                if (face != null)
                {
                    EdgeArrayArray edgeArrays = face.EdgeLoops;
                    foreach (EdgeArray edges in edgeArrays)
                    {
                        foreach (Edge edge in edges)
                        {
                            // Get one test point
                            XYZ testPoint = edge.Evaluate(0.5);
                            string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
                            TaskDialog.Show("Revit",edgeInfo);
                        }
                    }
                }
            }
        }
    }
}
See Also