BuiltInFailuresRebarShapeFailures Class

Failures about RebarShape.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresRebarShapeFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RebarShapeFailures

The BuiltInFailuresRebarShapeFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCircleMultiPlanarShape A circle can't be converted to multiplanar shape.
Public propertyStatic memberCircleUnbounded An unbounded circle can only be used to construct a spiral shape.
Public propertyStatic memberCurveOverconstrained Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
Public propertyStatic memberCurvesCollinear Collinear segments are not allowed in a Rebar Shape definition.
Public propertyStatic memberCurvesUnlooped Segments defining the Rebar Shape must be in a continuous loop.
Public propertyStatic memberCurveUnderconstrained Segment is underconstrained. It requires additional parameterized dimensions.
Public propertyStatic memberDefaultParamaterValuesIncorrect Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).
Public propertyStatic memberDepthDimensionNotExisted Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
Public propertyStatic memberDiagonalEdgesAreUnderconstrained Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)
Public propertyStatic memberDimensionLoose This dimension cannot be used to parameterize the Rebar Shape.
Public propertyStatic memberDimensionWithCommonLengthUnit A shape dimension is labelled with a parameter that uses the Common Length unit.
Public propertyStatic memberDimensionWithoutParameter Dimension has no parameter assigned to it.
Public propertyStatic memberFormulaDrivenDimension Dimension can't be driven by a formula parameter.
Public propertyStatic memberHooksAndEndTreatmentAtTheSameEnd Cannot add hooks and end treatments at the same end.
Public propertyStatic memberMultiPlanarDepth Multi-planar depth of Rebar Shape can't be too small.
Public propertyStatic memberMultipleArcsMustOverlap Multiple arcs are supported only if they are concentric and form a circle with an overlap.
Public propertyStatic memberParameterValueNotDefined Parameter assigned to the dimension has no value defined.
Public propertyStatic memberPlanarMultiPlanarShape The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
Public propertyStatic memberShapeFailure The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
Public propertyStatic memberWrongDepthDimensionLabel Multi-planar depth dimension label is already used for one of the planar shape parameters.
Top
See Also