BuiltInFailuresAutoRouteFailures Class

Failures about AutoRoute.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresAutoRouteFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AutoRouteFailures

The BuiltInFailuresAutoRouteFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAttemptToConnectNonSlopingElementToSlopedPipeError You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
Public propertyStatic memberAttemptToConnectNonSlopingElementToSlopedPipeWarning You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
Public propertyStatic memberDesignOptionConflictError The solution is failing to do the elements are not in the same Design Option.
Public propertyStatic memberDesignOptionConflictWarning The solution is failing to do the elements are not in the same Design Option.
Public propertyStatic memberDistributionTypeInvalid Selected distribution system type is invalid!
Public propertyStatic memberElementHasFlowCalculation This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
Public propertyStatic memberElementHasOpenConnection This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
Public propertyStatic memberFailedDowngradeCrossToElbow Failed to downgrade tee type to elbow type.
Public propertyStatic memberFailedDowngradeCrossToTee Failed to downgrade cross type to tee type.
Public propertyStatic memberFailedDowngradeTeeToCross Failed to upgrade tee type to cross type.
Public propertyStatic memberFailToDoCompatiblePhaseError The solution is failing to do the elements Phases are compatible.
Public propertyStatic memberFailToDoCompatiblePhaseWarning The solution is failing to do the elements Phases are compatible.
Public propertyStatic memberFailToIntersectParallelSegmentsError The solution is failing to do segments which are parallel and should intersect.
Public propertyStatic memberFailToIntersectParallelSegmentsWarning The solution is failing to do segments which are parallel and should intersect.
Public propertyStatic memberFittingParamsCauseGeometryToFailError The one of parameters for the fitting is causing the geometry to fail.
Public propertyStatic memberFittingParamsCauseGeometryToFailWarning The one of parameters for the fitting is causing the geometry to fail.
Public propertyStatic memberHighlightedElementDisconnected The highlighted element has been disconnected.
Public propertyStatic memberInappropriateSlopeForPipe The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
Public propertyStatic memberMismatchedSystemClassificationHasSystemWarning The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.
Public propertyStatic memberMismatchedSystemClassificationNoSystemWarning The selected fixture is assigned to a system with different classification.
Public propertyStatic memberMismatchedSystemTypeWarning The selected fixture is part of a different system. You may want to edit the system type and merge two systems.
Public propertyStatic memberNoAutoRouteSolutionFoundError No auto-route solution was found.
Public propertyStatic memberNoAutoRouteSolutionFoundWarning No auto-route solution was found.
Public propertyStatic memberNoFittingInProjectError The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
Public propertyStatic memberNoFittingInProjectWarning The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
Public propertyStatic memberNoFittingInRoutingError The fitting that is converted to was not defined. Please assign one in the routing preference.
Public propertyStatic memberNoFittingLoadedInProjectError The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.
Public propertyStatic memberNoSolutionInView There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
Public propertyStatic memberNotAllPartsWereConvertedCannotAddPlaceholderWarning Not all parts were converted. Placeholders could not be added to fill the gap (the gap was too small). Check the fabrication service definition for the system.
Public propertyStatic memberNotAllPartsWereConvertedPlaceholdersWereAddedWarning Not all parts were converted. Placeholders were added to fill the gaps. Check the fabrication service definition for the system.
Public propertyStatic memberNotEnoughRoomForFittingsError There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
Public propertyStatic memberNotEnoughRoomForFittingsWarning There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
Public propertyStatic memberNoValidSolutionAtSelectedPoint No valid auto-route solution at selected point.
Public propertyStatic memberOverrideFabricationPartFailed The fabrication part cannot be overridden. The button code you specified does not match the fabrication service. Please specify a different button code or check the fabrication service and try again.
Public propertyStatic memberSegmentDrawnFromWrongSideError The segment is being drawn from the wrong side to connect to the location you indicated.
Public propertyStatic memberSegmentDrawnFromWrongSideWarning The segment is being drawn from the wrong side to connect to the location you indicated.
Public propertyStatic memberSegmentsAngleTooGreatError The resulting angle between the segments is too great.
Public propertyStatic memberSegmentsAngleTooGreatWarning The resulting angle between the segments is too great.
Public propertyStatic memberSolutionIsOppositeToConnectionError The solution is in the opposite direction of the connection direction.
Public propertyStatic memberSolutionIsOppositeToConnectionWarning The solution is in the opposite direction of the connection direction.
Public propertyStatic memberSpecifiedAnglesNotCompatibleWithLayoutError The specified angles are not compatible with current layout.
Public propertyStatic memberSpecifiedAnglesNotCompatibleWithLayoutWarning The specified angles are not compatible with current layout.
Public propertyStatic memberUnableToMakeConnectionInDirection The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
Public propertyStatic memberUtilizationCoefficientOutOfRange The value for Coefficient of Utilization must be between 0 and 1.
Public propertyStatic memberZeroLengthSegmentError The solution is failing to do segments which are zero length.
Public propertyStatic memberZeroLengthSegmentWarning The solution is failing to do segments which are zero length.
Top
See Also