CategoryGetBuiltInCategory Method |
Gets the BuiltInCategory value corresponding to the given built-in category identifier.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static BuiltInCategory GetBuiltInCategory(
ForgeTypeId categoryTypeId
)
Public Shared Function GetBuiltInCategory (
categoryTypeId As ForgeTypeId
) As BuiltInCategory
public:
static BuiltInCategory GetBuiltInCategory(
ForgeTypeId^ categoryTypeId
)
static member GetBuiltInCategory :
categoryTypeId : ForgeTypeId -> BuiltInCategory
Parameters
- categoryTypeId ForgeTypeId
-
The built-in category identifier.
Return Value
BuiltInCategory
The BuiltInCategory value corresponding to the given built-in category identifier.
ExceptionsException | Condition |
---|
ArgumentException |
categoryTypeId is not a built-in category identifier. See Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
See Also