CategoryGetBuiltInCategoryTypeId Method |
Gets the ForgeTypeId identifying the given built-in category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ForgeTypeId GetBuiltInCategoryTypeId(
BuiltInCategory categoryId
)
Public Shared Function GetBuiltInCategoryTypeId (
categoryId As BuiltInCategory
) As ForgeTypeId
public:
static ForgeTypeId^ GetBuiltInCategoryTypeId(
BuiltInCategory categoryId
)
static member GetBuiltInCategoryTypeId :
categoryId : BuiltInCategory -> ForgeTypeId
Parameters
- categoryId BuiltInCategory
-
The built-in category.
Return Value
ForgeTypeId
The identifier of the given built-in category.
ExceptionsException | Condition |
---|
ArgumentException |
categoryId is not a valid built-in category. See Category.IsBuiltInCategoryValid(BuiltInCategory).
|
Remarks
See Also