CategoryIsBuiltInCategory Method

Checks whether a ForgeTypeId identifies a built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsBuiltInCategory(
	ForgeTypeId categoryTypeId
)

Parameters

categoryTypeId  ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a built-in category, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategoryValid(BuiltInCategory) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).
See Also