SolidOptions Class

A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSolidOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SolidOptions : IDisposable

The SolidOptions type exposes the following members.

Constructors
 NameDescription
Public methodSolidOptions Creates a new SolidOptions class with material and graphics style settings.
Top
Properties
 NameDescription
Public propertyExtraFaceAndEdgeHistoryKey Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.
Public propertyGraphicsStyleId Defines the graphics style id for the Solid.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMaterialId Defines the material id for the Solid.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SolidOptions
Top
See Also