Creates a new SolidOptions class with material and graphics style settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SolidOptions(
ElementId materialId,
ElementId graphicsStyleId
)
Public Sub New (
materialId As ElementId,
graphicsStyleId As ElementId
)
public:
SolidOptions(
ElementId^ materialId,
ElementId^ graphicsStyleId
)
new :
materialId : ElementId *
graphicsStyleId : ElementId -> SolidOptions
Parameters
- materialId ElementId
-
The material id for the Solid.
- graphicsStyleId ElementId
-
The graphics style id for the Solid.
Exceptions
See Also