DocumentNewOpening(Element, CurveArray, eRefFace) Method |
Creates a new opening in a beam, brace and column.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Opening NewOpening(
Element famInstElement,
CurveArray profile,
eRefFace iFace
)
Public Function NewOpening (
famInstElement As Element,
profile As CurveArray,
iFace As eRefFace
) As Opening
public:
Opening^ NewOpening(
Element^ famInstElement,
CurveArray^ profile,
eRefFace iFace
)
member NewOpening :
famInstElement : Element *
profile : CurveArray *
iFace : eRefFace -> Opening
Parameters
- famInstElement Element
- host element of the opening, can be a beam, brace and column.
- profile CurveArray
- profile of the opening.
- iFace eRefFace
- face on which opening is based on.
Return Value
Opening If successful, an Opening object is returned.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the family instance element does not exist in the given document. |
Remarks This method forms opening on a beam, brace and column.
See Also