DockablePaneId Class

Identifier for a pane that participates in the Revit docking window system.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBGuidEnum
    Autodesk.Revit.UIDockablePaneId

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DockablePaneId : GuidEnum

The DockablePaneId type exposes the following members.

Constructors
 NameDescription
Public methodDockablePaneIdCreates a new DockablePaneId instance.
Top
Properties
 NameDescription
Public propertyGuid The Guid of GUID-based enum object.
(Inherited from GuidEnum)
Top
Methods
 NameDescription
Public methodEquals Compares two Guid-based enum object based on their concrete class and GUID value.
(Inherited from GuidEnum)
Public methodGetHashCode Generates a hash code for this Guid-based enum object.
(Inherited from GuidEnum)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Operators
 NameDescription
Public operatorStatic memberEquality(DockablePaneId, DockablePaneId)Compares two DockablePaneId instances.
Public operatorStatic memberInequality(DockablePaneId, DockablePaneId)Compares two DockablePaneId instances.
Top
See Also