DockablePaneId Class

Identifier for a pane that participates in the Revit docking window system.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBGuidEnum
    Autodesk.Revit.UIDockablePaneId

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DockablePaneId : GuidEnum

The DockablePaneId type exposes the following members.

Constructors
 NameDescription
Public methodDockablePaneIdCreates a new DockablePaneId instance.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Top
Operators
 NameDescription
Public operatorStatic memberEquality(DockablePaneId, DockablePaneId)Compares two DockablePaneId instances.
Public operatorStatic memberInequality(DockablePaneId, DockablePaneId)Compares two DockablePaneId instances.
Top
See Also