ViewHide |
Exception | Condition |
---|---|
ArgumentNullException | Thrown when argument is . |
ArgumentException | Thrown when the set of elements to be hidden is empty or one of the elements can not be hidden. Also thrown when the set of elements to be hidden includes the view itself. |
InvalidOperationException | Thrown when document regeneration failed. |
Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents.
Also, elements cannot be hidden in Revit family documents (but they can be hidden temporarily using [M:Autodesk.Revit.DB.View.HideElementsTemporary(System.Collections.Generic.ICollection`1{Autodesk.Revit.DB.ElementId})]).
To hide a group completely, you must also include all members of all groups and nested groups in your input.