MEPFamilyConnectorInfo Class

MEP family connector information.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBMEPConnectorInfo
    Autodesk.Revit.DBMEPFamilyConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPFamilyConnectorInfo : MEPConnectorInfo

The MEPFamilyConnectorInfo type exposes the following members.

Properties
 NameDescription
Public propertyIsPrimary True if this is the primary connector.
(Inherited from MEPConnectorInfo)
Public propertyIsSecondary True if this is the secondary connector.
(Inherited from MEPConnectorInfo)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MEPConnectorInfo)
Public propertyLinkedConnector The linked connector or if there is no linked connector
(Inherited from MEPConnectorInfo)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from MEPConnectorInfo)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAssociateFamilyParameterId Gets the associate family parameter id of the specified connector parameter id.
Public methodGetConnectorParameterValue Gets the parameter value of the specified connector parameter id.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also