MEPFamilyConnectorInfoGetAssociateFamilyParameterId Method |
Gets the associate family parameter id of the specified connector parameter id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetAssociateFamilyParameterId(
ElementId connectorParameterId
)
Public Function GetAssociateFamilyParameterId (
connectorParameterId As ElementId
) As ElementId
public:
ElementId^ GetAssociateFamilyParameterId(
ElementId^ connectorParameterId
)
member GetAssociateFamilyParameterId :
connectorParameterId : ElementId -> ElementId
Parameters
- connectorParameterId ElementId
-
connectorParameterId is defined in the family connector element.
Return Value
ElementId
Returns valid ElementId if the connectorParameterId associates to one family parameter; otherwise returns invalid ElementId.
Exceptions
See Also