DefinitionBindingMapIterator Class

An iterator to a parameter definition to parameter bindings map.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDefinitionBindingMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class DefinitionBindingMapIterator : APIObject, 
	IEnumerator

The DefinitionBindingMapIterator type exposes the following members.

Constructors
 NameDescription
Public methodDefinitionBindingMapIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the binding that is the current focus of the iterator.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyKeyRetrieves the definition that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the map.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also