DefinitionBindingMapIterator Class

An iterator to a parameter definition to parameter bindings map.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDefinitionBindingMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class DefinitionBindingMapIterator : APIObject, 
	IEnumerator

The DefinitionBindingMapIterator type exposes the following members.

Constructors
 NameDescription
Public methodDefinitionBindingMapIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the binding that is the current focus of the iterator.
Public propertyKeyRetrieves the definition that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the map.
Top
See Also