SolidUtils Class

Contains utility functions for solid operations.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSolidUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SolidUtils

The SolidUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberClone Creates a new Solid which is a copy of the input Solid.
Public methodStatic memberCreateTransformed Creates a new Solid which is the transformation of the input Solid.
Public methodStatic memberFindAllEdgeEndPointsAtVertex Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
Public methodStatic memberIsValidForTessellation Tests if the input solid or shell is valid for tessellation.
Public methodStatic memberSplitVolumes Splits a solid geometry into several separate solids.
Public methodStatic memberTessellateSolidOrShell This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Top
See Also