SolidUtilsCreateTransformed Method |
Creates a new Solid which is the transformation of the input Solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Solid CreateTransformed(
Solid solid,
Transform transform
)
Public Shared Function CreateTransformed (
solid As Solid,
transform As Transform
) As Solid
public:
static Solid^ CreateTransformed(
Solid^ solid,
Transform^ transform
)
static member CreateTransformed :
solid : Solid *
transform : Transform -> Solid
Parameters
- solid Solid
-
The input solid to be transformed.
- transform Transform
-
The transform (which must be conformal).
Return Value
Solid
The newly created Solid.
Exceptions
See Also