SolidUtilsTessellateSolidOrShell Method |
This function facets (i.e., triangulates) a solid or an open shell. Each boundary
component of the solid or shell is represented by a single triangulated structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static TriangulatedSolidOrShell TessellateSolidOrShell(
Solid solidOrShell,
SolidOrShellTessellationControls tessellationControls
)
Public Shared Function TessellateSolidOrShell (
solidOrShell As Solid,
tessellationControls As SolidOrShellTessellationControls
) As TriangulatedSolidOrShell
public:
static TriangulatedSolidOrShell^ TessellateSolidOrShell(
Solid^ solidOrShell,
SolidOrShellTessellationControls^ tessellationControls
)
static member TessellateSolidOrShell :
solidOrShell : Solid *
tessellationControls : SolidOrShellTessellationControls -> TriangulatedSolidOrShell
Parameters
- solidOrShell Solid
-
The solid or shell to be faceted.
- tessellationControls SolidOrShellTessellationControls
-
This input controls various aspects of the triangulation.
Return Value
TriangulatedSolidOrShell
The triangulated structures corresponding to the boundary components of the
input solid or the components of the input shell.
Exceptions
Remarks
Every point on the triangulation of a boundary component of the solid (or
shell) should lie within the 3D distance specified by the "accuracy" input of some
point on the triangulation, and vice-versa. In some cases, this constraint may be
implemented heuristically (not rigorously).
See Also