SolidUtilsClone Method

Creates a new Solid which is a copy of the input Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Solid Clone(
	Solid solid
)

Parameters

solid  Solid
The input solid to be copied.

Return Value

Solid
The newly created Solid.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also