PreEventArgs Class

The class is used as a base class for the arguments for any pre-event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitEventArgs
      Autodesk.Revit.DB.EventsPreEventArgs
        Autodesk.Revit.DB.EventsPreDocEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PreEventArgs : RevitEventArgs

The PreEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
(Inherited from RevitEventArgs)
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitEventArgs)
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also