ElementSet Class

A set that contains element objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBElementSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementSet : APIObject, IEnumerable

The ElementSet type exposes the following members.

Constructors
 NameDescription
Public methodElementSetInitializes a new instance of the ElementSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of elements that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every item element the set, rendering it empty.
Public methodContainsTests for the existence of an element within the set.
Public methodEraseRemoves a specified element from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsertInsert the specified element into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
Example
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

string info = "Selected elements:\n";
foreach (ElementId id in selectedIds)
{
    Element elem = document.GetElement(id);
    info += elem.Name + "\n";
}

TaskDialog.Show("Revit",info);
See Also