ReferencePointArray Class

An array that contains reference objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBReferencePointArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ReferencePointArray : APIObject, 
	IEnumerable

The ReferencePointArray type exposes the following members.

Constructors
 NameDescription
Public methodReferencePointArrayInitializes a new instance of the ReferencePointArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyItemGets or sets a reference at a specified index within the array.
Public propertySizeReturns the number of references that are in the array.
Top
Methods
 NameDescription
Public methodAppend 
Public methodClearRemoves every reference from the array, rendering it empty.
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodInsert 
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Top
See Also